Welcome to the Creatures Wiki! Log in and join the community.

Talk:Macintosh port of Creatures

From Creatures Wiki
Jump to: navigation, search

Mac OS Compatibility and Emulation[edit]

Mac Requirements: PowerMac System 7.5 to 8.1, etc.
See also Macintosh.

I haven't actually checked whether Creatures runs under MacOS 8.5 - due to lacking a copy of 8.5 to install - but I'm told by others that to the best of their memory it doesn't. It definitely doesn't under 9.0. Maybe someone with the necessary software could check? Also, what's this 'Mac Advisory' mentioned in the requirements? --Fuzzie 15:35, 13 Feb 2005 (GMT)

From the archived support site at creatures.co.uk. --GreenReaper(talk) 15:51, 13 Feb 2005 (GMT)

I'm going to remove Malkin's edits about emulation unless someone pops up and says they've actually got Creatures for Mac working usefully under an emulator; having suggestions it *might* work is just going to lead people to hours of useless pain, as far as I can see.

For reference, this is my current knowledge: Mac-on-Linux doesn't work correctly on anything but Linux/ppc (which no-one is going to be using) and doesn't really like 7.5.3 anyway, sheepshaver is far too buggy to work, and qemu/pearpc are waaaay too slow (and you might as well be emulating Windows at that point). And that's about it for PowerPC emulators, as far as I'm aware. - Fuzzie 13:37, 8 Oct 2005 (UTC)

You're the expert on Macs, Fuzzie. What about mini vMac and a black-and-white palette? I wish I could find my CD so I could test it - getting the ROM and the emulator and the game together is probably a bit too hardcore for most, especially as the port wasn't handled too well in the first place. As you told me before, easier to buy Virtual PC and run it from there. - 02:13, 12 Oct 2005 (UTC)

vMac isn't a PowerPC emulator - it emulates m68k, the ooooold Mac processor type - so it has no chance at all of running Creatures. I'll go ahead and remove the emulation stuff and add an explanation. - Fuzzie 18:16, 15 Oct 2005 (UTC)

I have Creatures 1 installed on Basilisk II with OS 7.5.5 and although it naturally cannot run the game (being a 68k Mac emulator and not a Power Mac emulator) it is still interesting to look at the files. SheepShaver on the other hand currently supports Mac OS 7.5.2 to 9.0.4 under Linux, but only from OS 8.5 onwards under Windows which is no good. So it basically looks like emulators are pretty much out the question for running Creatures games - Don 19:37, 17 Oct 2005 (UTC)

Working under modern OSes[edit]

I've now had two reports of Creatures 1 working under recent versions of Classic with an up-to-date OS 9 install. Someone might want to work out exactly what's going on and update the article, or else I'll hopefully get to it sometime. Fuzzie 11:31, 9 June 2006 (UTC)

I have just installed Mac C1 under OS 10.4.7 and it runs with Classic 9 - Don 14:15, 25 September 2006 (UTC)