Welcome to the Creatures Wiki! Log in and join the community.


From Creatures Wiki
Jump to navigation Jump to search

Anyone want to link that script? It's on creatures-linux somewhere... --Nornagon 13:00, 15 Feb 2005 (GMT)

How can I create docked worlds in Linux? I tried it by installing Windows C3 in Wine and then telling the Linux DS where it is installed, but that didn't work and made the world switcher crash... And the article only says that an installer can be found on the Yahoo Groups things, but that group it moved to the Gameware Forums which aren't available anymore...
-- Toa-Nuva (user page / discussion) 19:04, 14 March 2009 (UTC)

Look at http://www.creaturetopia.org/viewtopic.php?f=7&t=201&p=2580 , this may help. I hve it not tested yet.--August0815 16:54, 16 March 2009 (UTC)

Look at http://danielmewes.dnsalias.net/~daniel/sylv-creatures/downloads/?S=A the orginal file?? and http://danielmewes.dnsalias.net/~daniel/sylv-creatures/manual.html--August0815 19:20, 16 March 2009 (UTC)

Thanks - but that doesn't work either. The installer with the GUI seems to work perfectly until the installation is nearly completed; but then it crashes, leaving me with a Windows-only C3. If I start DS in a console then, the console tells me it could find an installation of C3, but DS itself tells me that C3 is not installed, and even when I try to create an un-docked world, the world selection screen agent is just autokilled. The other (old) installer doesn't work at all and crashes as soon as I start it. :-/
I guess that these installers maybe just aren't compatible with a German C3 CD, since the folder names were translated into German (for example "My Agents" => "Meine Agenten")... :-(
-- Toa-Nuva (user page / discussion) 22:41, 17 March 2009 (UTC)

You are right.The first "c3installer.py" doesn´t find my dockingstation!!. But the old works fine.

  • 1. You must have dockingstation installed! ( at /usr/local/game)
  • 2. Try to run >sudo ./setup.sh ( my system Ubuntu 8.04,German C3 CD)
  • 3. After install goto /usr/local/game/creatures3 and edit dstation-installer with editor(su??!)
  • 3.1 Line63 ..$fullpath" | awk '{print $11}'`" to =>$..fullpath" | awk '{print $10}'`"
  • 3.2 Line653 ..$EXECUTE_NAME" | awk '{print $11}'`" to => ..$EXECUTE_NAME" | awk '{print $10}'`"
  • 4. Save and start dockingstation, the only "bug" is an permanent output in console "Tried to read auxiliary 2 when we only have 1 for directory 9" ; at the moment I don´t know why?--August0815 04:44, 18 March 2009 (UTC) (PS I "chmode" the complete /usr/local/games for general read+write so I don´t need su)

Well, the new installer did find my DS, but it crashed when the installation was nearly finished... And when I try to start the old installer, it just tells me ./setup.sh: 30: function: not found and quits.
-- Toa-Nuva (user page / discussion) 14:28, 18 March 2009 (UTC)

Sorry , forgot to say : rename the first Line in setup.sh

#!/bin/sh  to   #!/bin/bash--August0815 16:22, 18 March 2009 (UTC)

Strangely, that didn't work either - but it did work when I manually started /bin/bash before I executed ./setup.sh. o.O Installation worked without any problems, however, C3 itself doesn't start, and when I try to create a new world in DS while C3 is installed (and it doesn't matter whether it is a DS-only or a docked world), the world switcher just disappears...
Sometimes I think my computers are cursed... >.<
-- Toa-Nuva (user page / discussion) 17:50, 18 March 2009 (UTC)

The script "creatures3" is not very good.Some files are missing, and eg. langpick and lc2e have no rights to execute;Give me time to do some tests,--August0815 19:08, 18 March 2009 (UTC)

Sure. Anyway, thank you very much for all your answers! ;-) -- Toa-Nuva (user page / discussion) 19:28, 18 March 2009 (UTC)

Hello, try this:
First delete in your home dir. this => /home/yourname/.dockingstation
then open in usr/local/games/dockingstation => script dstation-install and change line 880

"Auxiliary 1 Worlds Directory" "$C3_MAIN/My Worlds/" to =>
"Auxiliary 1 Worlds Directory" "$DS_HOME/My Worlds/"

At my system this worked fine. Game startet , startup screen worked, sound OK, could get DS or C3 docked with DS gameplay .--August0815 18:30, 20 March 2009 (UTC)