Welcome to the Creatures Wiki! Log in and join the community.

Forum:Power Kit problem

From Creatures Wiki
Jump to: navigation, search
Forums: Index > Help desk > Forum:Power Kit problem

{{#ifeq:|Template||}}


I have got Creatures: The Albian Years. When I click on SPowerkit.exe, I receive following error from Vista Inspirat: Component comdlg32.ocx not correctly registered: file is missing or invalid. I downloaded Power Kit from Creatures Unlimited. More informations: I have opened C2PowerKit.zip with WinRar, WinZip and with Compressed (zipped) folders (when I open file with last mentioned thing, Windows tells me that is recommended to extract files and I did that). Then I created a new folder (Power Kit) in Creatures 2 directory where are files (in mentioned folder there is hackprog.ocx). I searched comdlg32.ocx on my computer, but it isn't finded, and I tried downloading program again. Note: PowerKit worked fine on Windows XP on my old computer. I'm sorry on my bad English, but I hope you understand what problem with Power Kit i have got.--95.156.164.11 14:14, December 26, 2009 (UTC)


SOLUTION:


I'm guessing you're working on Windows Vista or 7? I also had issues with the '.ocx' files, although not that specific one. My issue was with 'mscomctl.ocx' but I assume the fix is the same, as I had to take these steps to get the 'hackprog.ocx' to work also.


Firstly you will need to find a copy of the '.ocx' file you are missing. Try doing a Google search for the missing file. (Just checked then and it is easy enough to find a download for 'comdlg32.ocx').


Try running SPowerKit. If it still fails to work you will need to open up the cmd prompt as administrator (START -> Programs -> Accessories -> command prompt) then navigate to your 'C:\Windows\System' folder (on Windows 7 this is actually the 'C:\Windows\SysWOW64' folder).


Once there, type in 'regsvr32 comdlg32.ocx' and hit enter. A confirmation window should pop up saying the file has been successfully registered.


SPowerKit should now work. Good luck.


Oh, and as a final point the 'hackprog.ocx' needs to go in your 'C:\Windows\System' folder (again keeping in mind the SysWOW64 for Windows 7). You may need to register this file using the command prompt.


The installation instructions that come with SPowerKit are in German. I used Google Translate to get it back into English and learn where to put the 'hackprog.ocx' file.